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The STM32 Blue Pill is a low-cost ARM Cortex-M3 32-bit microcontroller board
based on the STM32F103C8T6 chip. 

It operates at 72 MHz with 64 KB Flash and 20 KB SRAM. The board provides 

multiple communication interfaces like USART, SPI, I2C, USB, and CAN. 
Unlike 8-bit boards like Arduino Nano, the Blue Pill offers faster performance, 

more memory, and additional peripherals, making it suitable for embedded 
systems, IoT, and robotics projects.

Pin Diagram

DC Motor (with L293D driver)
Servo Motor
Stepper Motor
IR Sensor
PIR Sensor
Ultrasonic (HC-SR04)
Bluetooth (HC-05/HC-06)
Seven Segment Display
RFID (EM18)

1. Description of STM32 Blue Pill 
Introduction 
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Applications

Specifications

 MCU: STM32F103C8T6 (ARM Cortex-M3, 32-bit, 72 MHz) 
Flash Memory: 64 KB (sometimes 128 KB on clones)
SRAM: 20 KB
Operating Voltage: 3.3V (5V tolerant I/O pins)
GPIO: 37
Communication Interfaces: - 3x USART - 2x I²C - 3x SPI - USB 2.0 FS - CAN 
bus 
Timers: 4 (16-bit), 1 (SysTick) 
ADC: 10 channels, 12-bit 
PWM: Multiple pins supported 
Power Supply: via USB, 5V pin, or 3.3V regulator

Robotics and Automation 
IoT Devices
Industrial Control Systems
Data Acquisition 
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 Motor Control
Sensor Interfaces

Material Required

Step 1: Install Arduino IDE (latest version).

 STM32 Blue Pill Board
USB to Serial Adapter 

Jumper Wires
Power Supply (5V via USB or external source)

2. Installing Arduino IDE for STM32 
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Step 2: Go to File → Preferences → Additional Board Manager URLs.

Step 3: Add the STM32 package URL: 
https://github.com/stm32duino/BoardManagerFiles/raw/main/package_stmicro
electroni cs_index.json 
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Step 4: Open Tools → Board → Board Manager, search for "STM32" and install
the package by STMicroelectronics. 

Step 5: Install required drivers (ST-LINK, CH340 for USB, or USB DFU drivers). 

Download CH340 Driver: 
https://drive.google.com/file/d/1JNB9n2InM8JCi14wzXzv3ECKrWqyHnfU/view 

Step 6: Select your board (Generic STM32F4 series) and Upload Method (Serial
/ ST-LINK / DFU). 

info@ssges.co.in



1 . LED

Step 7: Verify COM port detection under Tools → Port.

A Light Emitting Diode (LED) is one of the most widely used semiconductor
devices that emits either visible light or invisible infrared light when it is
forward biased. Remote controls, for example, generate invisible infrared light.

The LED converts electrical energy into light energy through a process called 

electroluminescence. When a voltage is applied across the LED, electrons and 
holes recombine in the semiconductor material, releasing energy in the form of 
photons (light).

3. Examples

Connections of LEDs & Switch with STM32 

PB0

PC13

PC14

PC15

STM32 PINS

G

B

R

Y

LED PINS
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PA0

PA3

PA2

PA1

STM32 PINS

SW4

SW3

SW2

SW1

SWITCH PINS

NOTE: Used same led pin for switch code 

2. OLED (Organic Light Emitting Diode)

AnOLED isa display technology made from organic materials that emit light
when current flows through them. Unlike LCDs, OLEDs don’t need a backlight
because they are self-emissive. This makes them thinner, lighter, and flexible,
allowing use in curved and foldable screens.
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An LCD is a widely used electronic display module found in devices such as
mobile phones, calculators, computers, and TVs. It is often preferred over
multi-segment LEDs and seven-segment displays because it can show custom
characters, symbols, and animations with ease. LCDs are also inexpensive, 
programmable, and versatile.

OLEDs provide bright colors, deep blacks, wide viewing angles, fast response,
and low power use.

They are commonly used in smartphones, TVs, laptops, smartwatches, digital 
displays, automotive dashboards, and AR/VR headsets.

Connections of OLED with LEDs

PB9

PB8

STM32

SCL

SDA

OLED PINS

3. LCD (Liquid Crystal Display)
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Features of LCD

Operating voltage: 4.7V – 5.3V
Two display rows, each supporting 16 characters
Low current consumption (~1mA without backlight)
Each character is displayed in a 5×8 pixel matrix
Supports alphabets, numbers, and symbols
Can operate in 4-bit or 8-bit mode

The DHT11 and DHT22 sensors are used to measure temperature and relative
humidity. These sensors contain a chip that does analog to digital conversion and
spit out a digital signal with the temperature and humidity. This makes them very
easy to use with any microcontroller. 

Connections of LCD with STM32

PB9

PB8

STM32 PINS

SDA

SCL

LCD PINS

4. DHT-11
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The DHT22 sensor has a better resolution and a wider temperature and humidity
measurement range. However, it is a bit more expensive, and you can only
request readings with 2 seconds interval. 

The DHT33 has a smaller range and it’s less accurate. However, you can request 

sensor readings every second. It’s also a bit cheaper.
Connections of DHT sensor with STM32

A relay is an electromechanical or electronic switch used to open and close
circuits. It works by energizing a coil that changes the state of its contacts.

NO (Normally Open): Contact remains open when the relay is not energized. 

When the coil is energized, the contact closes, allowing current to flow.
NC (Normally Closed): Contact remains closed when the relay is not 
energized. When the coil is energized, the contact opens, stopping the 
current flow.

PA0

STM32

DATA

DHT11 PINS

5. RELAY
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Relays are widely used in control panels, automation systems, and electronic
circuits. They allow a low-voltage signal to control higher voltages and
currents, making them useful for switching heavy loads safely.

Connections of Relay with STM32

Buzzers are commonly used in a wide range of applications such as alarms,
timers, and warning systems. They can also be used in electronic devices such
as mobile phones, computers, and other electronic devices to generate
different sounds and tones.

A buzzer is an electronic device that generates sound by converting electrical
energy into sound energy. It typically consists of a piezoelectric crystal, which
expands and contracts when an alternating current is applied to it, creating
sound waves.

PA1

STM 32

SIG

Relay PINS

6. BUZZER
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Connections of BUZZER with STM32

Connections of DC MOTOR with STM32

PA2

STM32

SIG

BUZZER PINS

7. DC MOTOR
A DC Motor is an electromechanical device that converts direct current (DC)
electrical energy into mechanical rotational energy.

Working Principle
When a current-carrying conductor is placed in a magnetic field, it experiences a
mechanical force that makes it rotate. The direction of rotation is determined
using Fleming’s Left-Hand Rule.

Robotics (movement control)
Toys and hobby projects
Quadcopters and drones
CD/DVD drives in computers and laptops
Small appliances and automation systems

Applications
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PA0

PA3

PA2

PA1

STM32

M1A

M2A

M3A

M4A

DC MOTOR PINS

8. SERVO MOTOR
A Servo Motor is an electrical device used to rotate and position objects
precisely, such as in robotic arms, cameras, and automation systems.

It consists of a DC motor (sometimes AC motor) combined with a feedback 
control system. The built-in error-sensing feedback mechanism continuously 
monitors the output position and corrects it, ensuring accurate control of 
angular velocity and position.

It is a closed loop system where it uses negative feedback to control motion and
final

position of the shaft.It is not used for continuous rotation like conventional 

AC/DC
motors.It has rotation angle that varies from 0° to 380°.
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Connections of SERVO MOTOR with STM32

PA0

PA0

PA3

PA2

PA1

STM32

STM32

B4

B3

B2

B1

CTRL

STEPPER PINS

SERVO MOTOR PINS

9. STEPPER - MOTOR
A Servo Motor is a special type of motor used for precise control of angular
position, velocity, and acceleration. It is a closed-loop system that uses
negative feedback to continuously adjust and control the motion of its shaft.

Unlike conventional AC/DC motors, a servo motor is not designed for
continuous rotation. Instead, it operates within a limited angle range, typically
0° to 180° (some extended types up to 360° or more).

Connections of STEPPER MOTOR with STM32
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10. IR SENSOR
An Infrared (IR) Sensor is an electronic device that uses infrared light to detect
objects, measure heat, or sense motion in its surroundings. All objects emit
some form of thermal radiation in the infrared spectrum, which is invisible to
the human eye but can be detected by IR sensors.

11. PIR SENSOR
A PIR sensor is an electronic device that detects infrared (IR) radiation emitted
by objects. It is mainly used in motion detection systems, security alarms, and
automatic lighting applications. PIR sensors are popular because they are 

simple, low-cost, and reliable for detecting human presence or movement.

An IR sensor mainly consists of:

IR LED (Emitter): Emits infrared light.
IR Photodiode (Detector): Detects the reflected IR light. Its resistance and 
output voltage change depending on the amount of IR light received.

This combination allows IR sensors to detect objects, measure distance (basic 
level), and sense motion.
Connections of IR SENSOR with STM32

PA0

STM32 IR PINS

DOUT,B-LED
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Pin Configuration (3 Pins)

The HC-SR04 ultrasonic module works on the principle of SONAR and RADAR to
measure distance. It can detect objects from 2 cm up to 400 cm. The sensor
consists of an ultrasonic transmitter, receiver, and a control circuit. When a
trigger pulse is applied, the transmitter generates eight pulses of ultrasound at 
40 kHz, which travel through the air and get reflected back as an echo when 
they hit an object.

Pin 1 (VCC): Connects to the +5V DC supply
Pin 2 (OUT): Output pin, carries the detected IR signal to a microcontroller or
amplifier
Pin 3 (GND): Connects to ground

(In some PIR sensors, resistors like 100K or 47K are internally connected for 

stability.)
Connections of PIR SENSOR with STM32

PA0

STM32

OUT

PIR PINS

12. ULTRASONIC SENSOR
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The Echo pin of the sensor goes high until the reflected signal is received. The
duration of this high state corresponds to the total travel time of the sound
wave. Since the wave travels to the object and back, the time is divided by two,
and using the known speed of sound, the exact distance of the object can be
calculated.

Connections of ULTRASONIC SENSOR with STM32

Bluetooth is a wireless communication technology used in devices like
headsets, game controllers, keyboards, mice, and other consumer electronics.
It works within a range of up to 100 meters, depending on environment and 
hardware conditions.

It follows the IEEE 802.15.1 standard for building Wireless Personal Area 
Networks (PANs) and uses Frequency-Hopping Spread Spectrum (FHSS) to 
send data securely. The module communicates with microcontrollers through 
serial communication (USART), making it simple to use with Arduino or STM32.

PA0

PA1

STM32

TRIG

ECHO

ULTRASONIC PINS

13. BLUETOOTH
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A Seven Segment Display (SSD) is a simple electronic display device used to
show numerical digits (0–9) and a few characters like A, B, C, E, F, H. It is made
up of 8 LEDs — seven LEDs form the segments labeled a–g, and one LED is used 
for the decimal point (dp). By turning ON or OFF different segments, digits and 
characters can be displayed.

Each SSD has 10 pins: 

1. Install a Bluetooth Terminal app on your smartphone.
2. Turn on the Bluetooth of your phone.
3. Search for available devices and select the module name (e.g., HC-05 or HC-

06).
4. If prompted for a password, enter 1234 (default).
5. Once paired, open the Bluetooth Terminal app.
6. Go to the list of paired devices and select the same module (HC-05/HC-06).
7. After a successful connection, you can start sending and receiving data 

wirelessly.

14. SEVEN SEGMENT DISPLAY

Connecting Bluetooth Module (HC-05/HC-06)

Connections of BLUETOOTH with STM32

PA9

PA10

STM32 PINS

TX

RX

BLUETOOTH PINS
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Common Anode (CA): All anodes are connected together at the COM pin.
Segments light up when their cathode is connected to GND.
Common Cathode (CC): All cathodes are connected together at the COM
pin. Segments light up when their anode is connected to VCC.

8 pins for the segments (a–g + dp) and 2 pins as common terminals (COM). The
COM pins are internally shorted, so you only need to use one of them.

RFID (Radio Frequency Identification) is a wireless identification technology
that uses radio waves to detect and identify the presence of RFID tags. Similar
to a barcode reader, it is used to identify people, objects, or goods. However, 
unlike barcodes, RFID does not require direct optical scanning. The RFID tag 
only needs to be within the reader’s range to be detected.

Types of Seven Segment Displays

Connections of SEVEN SEGMENT DISPLAY with STM32

PA0

PA3

PA2

PA1

STM32 PINS

D

C

B

A

SSD PINS

15. RFID (EM-18)
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Unlike barcodes that can get damaged or unreadable, RFID tags are generally
more durable and reliable. Each RFID tag carries a unique ID, making the system
highly secure and efficient.

Attendance systems: Each person is assigned a unique RFID tag for
identification.
Access control: Used in companies to allow only authorized employees.
Asset and goods tracking: Helpful in inventory management and logistics.
Automated toll collection: RFID tags on vehicles enable quick toll payments
without stopping.

Applications of RFID

Connections of RFID with STM 32

PA10

STM32

TX

RFID 
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